Lawyers have opened an investigation into the failure of the TSS and OSS sensors in Ford Edge vehicles

Ford Motor

Ford-Logo small

 

The TC (TSS) and Output Speed Sensor (OSS) are transmission speed sensors which are used to calculate the actual gear ratio of the transmission while in use. After registering data, the two transmission speed sensors, also commonly referred to as a vehicle speed sensor (VSS), send data to the Powertrain Control Module (PCM); which compares these two inputs and calculates which gear the transmission should be engaged for efficient driving.

Consumers have reported failure of these sensors resulting in the inability to accelerate and or harsh or improper shifting, both of which pose a significant safety issue for the occupants of the vehicle.

If you have a Ford Flex and experienced a problem with the TSS or OSS sensors of your vehicle we would like to hear from you. You may contact us privately using the contact attorney privately box below and/or share your story publicly using the submit button.


James T. said
407 days ago
2007 F150 5.4 V8 Triton


James T. said
407 days ago
2007 F150 V8 5.4 Triton motor have same problem with the motor blown need new motor


G. said
407 days ago
Just Purchased a 2014 Edge last Sunday. Two days later heard a noise that we could not identify. Took the car into dealer and don't have it back yet. We were told today it, more than likely, is PTU. We have signed our lives away for a car we do not have yet. Good we asked for extended warranty. but what else could go wrong?


Laurie C. said
403 days ago
Yes. I am happy to see this post. I have a problem with my lincoln mkx which has the same transmission as the ford edge. It is transmission 6F50 FWD 6 speed automatic with 3.16 ratio. It is known to have problems. My cars has exact same symptoms and I can't drive it. It only has 70k miles on it (2008). Diagnosising requires teatdown of transmission. I am in san diego, California.


Arvie R. said
401 days ago
My 2008 Ford Edge has engine problems after hitting 90,000 miles. At first it sounded like a transmission problem and the vehicle could not go faster than 45mph. Eventually the vehicle got to a point where it no longer starts and is now inoperable.


Gretchen J. said
400 days ago
We have an issue with our Ford F-150 Lariat. Recal for OSS. It's been 5 months with no vehicle. Software fix was done Monday and did not work. Multiple calls to Ford and their Customer Service is a joke. They offered nothing


Gretchen J. said
400 days ago
We have an issue with our Ford F-150 Lariat. Recal for OSS. It's been 5 months with no vehicle. Software fix was done Monday and did not work. Multiple calls to Ford and their Customer Service is a joke. They offered nothing


WILLIAM M. said
395 days ago
My 2008 Ford Edge 2WD transmission is failing and it is the TSS/OSS sensors. It has 145K, very expensive repair (vehicle is at AAMCO transmissions now).
Called FORD MOTOR CO, they offered nothing.


WILLIAM M. said
395 days ago
My 2008 Ford Edge 2WD transmission is failing and it is the TSS/OSS sensors. It has 145K, very expensive repair (vehicle is at AAMCO transmissions now).
Called FORD MOTOR CO, they offered nothing.


Steven W. said
395 days ago
2007 Ford Edge AWD - had sensor issue and was told they had to upgrade the sensor chip the first time I took it in. As of today September 21, 2016 when they were replacing my recalled corroded gas tank, my traction control light came on. I was told for a $99.00 diagnostics procedure, (which I refused to pay), they would find out why. The alleged result of that test is I have a short in the sensor and for $890.00 they can replace the sensor.


Ernest C. said
388 days ago
Having problems withmy 2008 Ford Edge. Tramissions jerking.


Ernest C. said
388 days ago
Issues with my 2008 Ford Edge Transmission jerking, no speed or odemetor reading.


Tanner L. said
383 days ago
Just found out I have this issue with my 2007 Edge. Minimum of $1100 to fix it. Waiting to see if there are any additional problems with the PCM.


Jean C. said
381 days ago
I just received news my PTU is gone and needs replacing. I have a 2008 Ford Edge AWD.


Rene P. said
365 days ago
I am loosing slot of money do to .y 2006 Ford freestyle I want to join the law suite


Melissa C. said
346 days ago
Same issue with Lincoln MKX. I also have the traction control light coming on... Not sure if that is related to this issue or not.


Carla H. said
325 days ago
2005 F150 5.4 v8...had to replace all spark plugs last year and hadto buy dpecial tool because a couple broke off. Autozone told me it happens on all 2005 models. Plugs were $13.97 each and spevial tool was $150. Now a year later I just got done replacing pligs agsin plus an ignition coil. Engine light is off now but truck will barely pull a hill. Runs terrible, has no power and misses like crazy. I have 122,000 miles. This is rificulous. How can I join class action suit


Karl R. said
315 days ago
2008 Ford Edge. Bought it in 2011 and started having shifting problems a year later. Fixed twice but still had issues until one shop saw the TSB about the shifting sensors and fixed it. 2 years later has started again.


Rex H. said
284 days ago
I have 2008 Ford Edge with the senoe problem


Rebecca G. said
280 days ago
No solution but lots of info on what inspections I performed, was advised to perform, and results or non-results. List of safety issues it has caused for me and my family!


Jillian W. said
264 days ago
We took our Ford Edge 2007 to a ford dealership/service department and they said we needed a new transmission! We replaced it, cost us greatly and the shudder still persists.


harry f. said
257 days ago
08 ford edge failed sat.pm. no od reading check engine light on had to back up my driveway not any power going in foreware ntsb shoud get involed had to have car toled to ford dealer two days in shop add my name to suit on a fixed income could use repair money back


David S. said
245 days ago
Yes, TSS and OSS failure on my 2008 Edge


David S. said
245 days ago
yes, at 103k the TSS + OSS have failed on my 2008 Edge


Jaime S. said
245 days ago
I have a 2007 ford edge, and I have had countless problems with this vehicle. From a rear wheel speed sensors, numerous misfire in cylinder 4, random rpm (low and high spikes) which lead to rough idles or rough gear shifts with shaking of vehicle at about 40mph, several fuel injector codes pop up, faulty break booster which was replaced, and now black greasy sludge leaking from my ptu which is a extremely costly repair. How is there not more recalls on this vehicle. I for one am over the edge with repairs. Living paycheck to paycheck, still making payments and having no other forms of transportation this is very disheartening. I would like to join this class action


Paula V. said
242 days ago
I just posted under the Ford PTU issue as well. I'm sure that I have this issue as well. This is what I described in my other post. Where the transmission fails to engage or move to the correct gear. It revs usp high trying to engage...and I was told by my personal mechanic it was the sensors.


Joshua M. said
238 days ago
My 2008 ford edge is showing signs of faulty speed sensors. I recently purchased the vehicle


Joshua M. said
238 days ago
My 2008 ford edge is showing signs of faulty speed sensors. I recently purchased the vehicle


Matt R. said
236 days ago
Purchased a 2008 Edge with faulty speed sensors. Does not make me feel safe at all!


Benjamin W. said
231 days ago
2008 Ford Taurus X. Looses power makes some violent jerks and clunks then returns to normal. When this condition occurs the read out on the dash says tire pressure monitor failure.


Aric B. said
215 days ago
Yes having same problem the abs and traction control lights come on all the time on my 2008 ford edge and the little wrench light and it looses all power want move also while driving it shifts hard .


Kevin P. said
214 days ago
2008 Ford Edge 69,000 miles and both sensors need to be replaced?


Jenny R. said
213 days ago
I have a 2009 Lincoln MKX, the transmission bucks when trying to accelerate. According to the local Ford dealer it will be quite expensive just to diagnos this issue.


Roger J. said
210 days ago
I took my 2009 Ford Flex to the dealer numerous times for harsh transmission shifts and a jerky transmission when traveling at a steady speed. This started early in it's life and never stopped. Transmission failed recently, but it does have 180,000 miles on it. It still bothers me because the never fixed the problem early on and I feel that shortened the life.


Karl R. said
208 days ago
2008 edge been in shop 3 time and has had OSS sensor replaced.
Going in again,sane issues.


Gabriel M. said
204 days ago
My 2008 Edge has been having the sensors problem since last September, can't go over 60mph it starts jerking amd the gauges go crazy.


Amity W. said
203 days ago
Just had the sensor problem last night - driving with my two young kids and couldn't accelerate over 5 mph. Wrench light, airbag light, odometer wasn't working, tire pressure sensor issue, SLAMMED into reverse, etc...had towed to dealership. We will see...


Rachel B. said
192 days ago
I have a 2008 Ford Edge that I bought used in 2014. It has a bad output speed sensor just like so many other edges. The cheapest place I have found to fix this issue was still over $600. Needs to be recalled. No reason these should all be going bad.


David L. said
185 days ago
My wife was driving our 2008 Lincoln MKX on a busy street in Scottsdale when it happened to her. This is extremely dangerous, at high RPM she was able to crawl off the road and get out of speeding traffic. Dash lights were all coming on, no speedometer or odometer. If this would have happened just a few seconds earlier when she was making a left turn, she would have been t-boned by on coming traffic. I would be surprised if this has not already caused serious injury.


brad m. said
180 days ago
2008 Lincoln MKX with TSS/OSS problems estimates are $400-$900


SONJA H. said
173 days ago
My 2013 ford focus SE Clutch actuator has been replaced and adjusted/reprogramed once. Same issues occur. Vehicle losses power, shakes, and vibrates. When merging into traffic the vehicle will lose power possible causing an accident. Won't crank on a daily.This is an ongoing problem and it is unsafe.


Marguerite P. said
172 days ago
Driving over bridge, dash went blank with dashes, wrench and airbag lights. Pulling in to gas station, turned off car, turned it back on and dash was fine but loud thud when turned the key over. Attempted to change gears (drive, reverse, etc) and each time heard a loud thud. 86xxx miles on the car, 2008 Ford Edge. Worried because I have my 2 year old with me at all times!


Jay H. said
162 days ago
mercury 2006 mariner --transmission failure in traffic---found out on internet about multiple complaints about ford escapes with ford cd4e transmission failures--2004 thru 2008--ford refuses to recall ---transmissions are replaced at cost and transmissions fail again and again whether by dealer or shops--this is a design issue


Tammy A. said
162 days ago
I have an 08 with sensors problem.


Wilford L. said
156 days ago
2010 Ford Edge AWD with 46k. Noticed drop of black fluid on garage floor. Took it to dealer and they said that the fluid in the power take-off unit overheated and degraded the valve seals. They told me they had to replace the entire unit at $915.00 and labor at $665.00. I asked it there were any recalls or complaints about a similar problem and the answer was "sometimes it happens". I would like to know if there is anything you can do to help me.


Sherman B. said
145 days ago
2008 Lincoln MKX bad TSS / OSS.....


Rondall J. said
138 days ago
Have o8 ford edge had probblem intermittent since we bought it new. Stop at light transmission seems to be slipping then makes clunk and works normal for months. Last month happend on vacation thought would have to be towed made it to gas staion shut car off after speedometer went to 0 while moving check engine light air pressure and airbag ligts came on . Shut car off for a minutes. Started car put in drive made loud clumk was normal rest of trip. Month later (last night) doing it again. A ton of videos on YouTube showing exact probblem .should be recall deffective car just turn 100k miles while on vacation. Called dealers Kerry and Colrain ford act like they never heard of probblem. Would have to scope motor for $125 k owing their will be no codes with lights off on dash criminal.


Rondall J. said
138 days ago
Have o8 ford edge had probblem intermittent since we bought it new. Stop at light transmission seems to be slipping then makes clunk and works normal for months. Last month happend on vacation thought would have to be towed made it to gas staion shut car off after speedometer went to 0 while moving check engine light air pressure and airbag ligts came on . Shut car off for a minutes. Started car put in drive made loud clumk was normal rest of trip. Month later (last night) doing it again. A ton of videos on YouTube showing exact probblem .should be recall deffective car just turn 100k miles while on vacation. Called dealers Kerry and Colrain ford act like they never heard of probblem. Would have to scope motor for $125 k owing their will be no codes with lights off on dash criminal.


Rondall J. said
138 days ago
Have o8 ford edge had probblem intermittent since we bought it new. Stop at light transmission seems to be slipping then makes clunk and works normal for months. Last month happend on vacation thought would have to be towed made it to gas staion shut car off after speedometer went to 0 while moving check engine light air pressure and airbag ligts came on . Shut car off for a minutes. Started car put in drive made loud clumk was normal rest of trip. Month later (last night) doing it again. A ton of videos on YouTube showing exact probblem .should be recall deffective car just turn 100k miles while on vacation. Called dealers Kerry and Colrain ford act like they never heard of probblem. Would have to scope motor for $125 k owing their will be no codes with lights off on dash criminal.


Matt E. said
135 days ago
My 07 fwd Edge went out when I was driving on the freeway Ford didn't care, but it costed me a new transmission. 4700


Georgia B. said
130 days ago
My 2008 Lincoln MKX went out while I was driving had to have it towed. It cost $820.00. That was about 2 months ago and I am still having issues. May possibly be the transmission now.


Steven h. said
123 days ago
2015 ford edge transfer case is leaking and needs to be replaced. Dealer said $1900.00.


Aaron W. said
116 days ago
2008 ford Edge. AWD 155k miles. Same exact issue. I'm going to replace the sensors, fingers crossed. The Lincoln MKX is the exact same vehicle, but with shinnier bells and and whistles. Don't Buy 07-09 ford edge or lincoln MKX


Brian H. said
116 days ago
In process of changing myself. Oss/tss failure.


Clint G. said
110 days ago
Same issue for me - 2006 Ford Edge. Not yet repaired.


Marc S. said
108 days ago
2008 Lincoln MKx most of lights are on the dash and when I can get the car to start I don't have my RPMs/speed/temp the protection mode light flashes because the car doesn't want you driving it with un-recorded miles. Taking into dealer tomorrow to have TSS/OSS sensors replaced to fix issues. Just had PTU replaced 1k miles ago, PTU seal replaced 2 months before PTU, replaced cooling system TWICE and car still overheats and had engine replaced 5k miles ago. $7,500 in repairs in the past 3 months plus rentals. I cannot take much more, only paid $13k for it....


DONNA M. said
101 days ago
YES~!SHIFT IS LOCKED MFT WENT OUT ..ALL OF A SUDDEN MANY ISSUES


christine i. said
99 days ago
I have a 2008 ford edge around 99,500 miles it shifts hard around 25 mph then again at 45 mph when it shifts it has a hard kick back


christine i. said
99 days ago
I have a 2008 ford edge around 99,500 miles it shifts hard around 25 mph then again at 45 mph when it shifts it has a hard kick back


Mark T. said
97 days ago
2008 Ford Taurus x with 6F50 transmission. OSS failed. Trans leaks - hard shifts, stutters. Only 71,000 miles.


said
77 days ago
My 2007 Ford Edge is having the same problem with the engine and transmission due to a sensor. Sometimes it will not go forward and feels like something dropping underneath the car.


Brian A. said
77 days ago
I have a 2007 Lincoln MKX transmission started shifting hard and jeeking at low RMPM's. Was TSS and OSS sensors. In the prosess of replacing them now. 121000 miles. The transmission was replaced when we purchased it with 76,000 miles on it


Brian A. said
77 days ago
I have a 2007 Lincoln MKX transmission started shifting hard and jerking ng at low RMPM's. Was TSS and OSS sensors. In the prosess of replacing them now. 121000 miles. The transmission was replaced when we purchased it with 76,000 miles on it


Mark C. said
74 days ago
2008 Ford Expedition with 6F55 transmission showing all classic symptoms of failed OSS at 110,000 miles.


Mark D. said
72 days ago
Have ford edge 2008 - tss and oss sensors have failed. Dealer wants 1000 CAD.


Thomas C. said
72 days ago
I have a 2008 Ford Tauraus SEL AWD. Had same problem, clunking noise, erratic shifting. Have taken to Ford dealer and Car Max (where I bought vehicle) and no one could duplicate problem, couldn't do anything. Transmission quite, took to AAMCO, diagnosed it as OSS and TSS sensors plus other things now. "$5000.00"


Aric B. said
70 days ago
No I don't have a solution but also have the same problems with my wife's 2008 ford edge and it's been a mess cause we bought it to replace our flooded vehicles from the great flood of 2016 in Louisiana and still ended up with somthing not dependable and can't afford to get it fixed.


Kevin D. said
61 days ago
2008 Ford Edge 80Kmiles. TSS and OSS sensors have gone bad. Car was taken in once under power train warranty with initial symptoms of hard down shift. Again was taken in outside the power train warranty and told the "computer needed to be reconfigured" Now the typical wrench light has come on with the same no acceleration and hard shifting. It's currently in the shop awaiting cost.


Andrea O. said
60 days ago
2008 Ford Edge; 100k miles; ODO data error, hard shifting, no acceleration


Natasha F. said
59 days ago
2008 Ford Edge.. a little over 100k miles... drove fine when I parked it.. went to leave for work the next day and it shifted hard into reverse.. tried to drive it.. hardly any power in drive but moves fine in reverse


Sandra N. said
57 days ago
2008 Ford Edge 99,000 miles just paid $850.00 to replace turbine sensor and output sensor and my car is still losing acceleration at times while driving. Thank goodness I wasn't on the freeway when the sensors went because I had my grandchildren with me and the car abruptly lost power, and was hard shifting....


don h. said
56 days ago
2008 Lincoln MKX is kicking back while driving. And occasionally it shifts hard or sticks in low gear.


Jonathan g. said
42 days ago
Will not shift into gear stays low..an occasionally jerks..very un reliable for my family....2005 FORD FREESTAR...


Sarah D. said
41 days ago
2009 Ford Edge and have major issues with shifting and jerkiness at high speeds. Sometimes the odomoeter goes completely out and we cannot accelerate at all. It's very scary and we have to turn car off. When we restart, it jerks and clanks very bad like the engine is about to fall out!


Volney B. said
39 days ago
2008 Ford Taurus Limited I have the same problem. I have replaced both sensors and it has helped somewhat, however; I still experience the problem every now again especially when shifting form 1st to 2nd gear. Ergo, I am convinced that the problem has been resolved by the replacement of the sensor.


Laura A. said
36 days ago
Hello, I have a 2009 Ford Flex and I have been experiencing a hard shift and thump if shifting gear into reverse. I took it in to Ron Tirepelli Ford in 2015, and this is what they reported and quoted what the problem was, my TSS and VSS needs replacing and now they say it may be more. I just seen this while trying to seek information concerning this problem. If this is still in effect please contact me. Thanks


Audrey F. said
29 days ago
I have a 2007 Ford Edge and I am experiencing a few problems with my transmission.


Patti H. said
25 days ago
Same problems with 2007 Ford Edge. Shudder/shake/vibration around 1500 rpms. I have replaced spark plugs and a bad coil pack. Didn't help at all. I was told that I needed a pcm all in one computer pack that housed all the sensors. Going for a second and third opinion. Very irritating.


Chris V. said
23 days ago
My 2008 ford edge is currently in the shop getting an input and output sensor teplaced thatbis locate INSIDE the transmission sonits costing me $1400. I bought the vehicle in 2015 with 80,000 miles on it and its alway had a problem shifting, where the vehicle neede to be turned off and on to reboot.


Chris V. said
23 days ago
2008 ford edge. Sensor problems for 2 years now. Vehicle breals down randomly while driving on highways and almost causing accidents. I am noticing a similar issue with many 2008 ford edges. Something needs to be done.


Chris V. said
23 days ago
2008 ford edge. Sensor problems for 2 years now. Vehicle breals down randomly while driving on highways and almost causing accidents. I am noticing a similar issue with many 2008 ford edges. Something needs to be done.


Jordan M. said
22 days ago
I have a 2011 taurus with a 6f50 transmission same as the 08 flex. Both of my sensors went out. I changed them myself but ford knows about the problem.


Jordan M. said
22 days ago
I have a 2011 taurus with a 6f50 transmission same as the 08 flex. Both of my sensors went out. I changed them myself but ford knows about the problem.


Enesha R. said
22 days ago
I have a 2008 Ford edge and I am having the same tss/oss sensors issue as well. Can not believe that when I was looking for a solution for my problem found this and there is so many with the same exact problem. Just don't understand why with all of the reports this would not be a recall.


Enesha R. said
22 days ago
I have a 2008 Ford edge and I am having the same tss/oss sensors issue as well. Can not believe that when I was looking for a solution for my problem found this and there is so many with the same exact problem. Just don't understand why with all of the reports this would not be a recall.


Enesha R. said
22 days ago
I have a 2008 Ford edge and I am having the same tss/oss sensors issue as well. Can not believe that when I was looking for a solution for my problem found this and there is so many with the same exact problem. Just don't understand why with all of the reports this would not be a recall.


Enesha R. said
22 days ago
I have a 2008 Ford edge and I am having the same tss/oss sensors issue as well. Can not believe that when I was looking for a solution for my problem found this and there is so many with the same exact problem. Just don't understand why with all of the reports this would not be a recall.


John M. said
21 days ago
2008 Ford Edge 92,000 miles transmission sensor replacement $1083.57
Despite all dealership service.


John M. said
21 days ago
2008 Ford Edge 92,000 miles transmission sensor replacement $1083.57
Despite all dealership service.


Adam W. said
17 days ago
First I had the engine replaced in my 2007 Ford Edge, then 2 weeks later, the wrench light, airbag light came on, vehicle wouldn't accelerate, when restarted, it slammed hard into reverse. I had no idea this issue was so common!


Jeannine F. said
15 days ago
I have a Ford 2008 Edge with about 90,000. My car will not go into reverse or drive at all. Its like its in constant neutral. I have to put it into Lo and move up to drive to get it to engage. The car has experienced hard shifts from park to reverse or even when changing gear, but nothing significant till now. My car is currently over at the mechanic and guessing that both sensors will need to be replaced. The scary part is that alot of people are having issues while driving?!?! I don't understand why Ford has not addressed this issue knowing that it could cause serious harm.


Jeannine F. said
15 days ago
I have a Ford 2008 Edge with about 90,000. My car will not go into reverse or drive at all. Its like its in constant neutral. I have to put it into Lo and move up to drive to get it to engage. The car has experienced hard shifts from park to reverse or even when changing gear, but nothing significant till now. My car is currently over at the mechanic and guessing that both sensors will need to be replaced. The scary part is that alot of people are having issues while driving?!?! I don't understand why Ford has not addressed this issue knowing that it could cause serious harm.


juan g. said
10 days ago
07 ford edge same problem went to ford and cant find any problems some one have to fix this problem transmission speed sensors love my car the car experienced hard shift and on freeway transmission gears up and down can drive on freeway 120.000 miles on the car,, grand prairie ford belt line road my wife drives this car what can we do dallas texas,,why the dealership wont fix this problem on this cars what up ford ,,,,, ford wont drive texas no more !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Barton D. said
6 days ago
2008 Ford Edge Limited. I am having the 3rd gear/reverse slipping/baning. Just replaced the TSS/OSS sensors with brand new ones and problem persists. 106,000 miles.


Sharon L. said
5 days ago
2008 Ford Taurus X - Less that 100k miles - have been dealing with the same issue for quite some time. Could not be reproduced by my mechanic so we did not have it fixed. Dash Odometer and Speedometer stop working. Fuel Light, Engine light and Wrench light come on. Pull over and turn off car to reset the dash, When you start the car again you need to hard accelerate, then the car 'Drops' hard into gear and starts moving. Still paying on the car. Frustrated! Car is at the Mechanic now - he is changing the TSS and OSS. Fingers crossed that it works!


Sharon L. said
5 days ago
2008 Ford Taurus X - Less that 100k miles - have been dealing with the same issue for quite some time. Could not be reproduced by my mechanic so we did not have it fixed. Dash Odometer and Speedometer stop working. Fuel Light, Engine light and Wrench light come on. Pull over and turn off car to reset the dash, When you start the car again you need to hard accelerate, then the car 'Drops' hard into gear and starts moving. Still paying on the car. Frustrated! Car is at the Mechanic now - he is changing the TSS and OSS. Fingers crossed that it works!


Michelle J. said
5 days ago
2008 Ford Edge at the shop now due the same issue of car acting like it just slips into neutral. Sometimes I'm lucky because I'm in a parking lot and I can just turn the car off and let it "rest" for a minute but it still jerks and clanks like the engine is about to fall out. Other times, I'm a stop light, hit the gas to go no acceleration at all. It's scary as hell.


Jonathan B. said
4 days ago
2008 Ford Edge with hard shifting and tss error code

Submit a Response Are you having the same issue? Do you have a solution? Either way, chime in!

I would like to speak with a lawyer about my legal rights in this matter.

Same or similar issue but with a different company?

I would like to join the lawsuit.

Sign up for the Got a Class Action newsletter?

I have read and agree to the Terms and Conditions.

Contact A Lawyer Privately

  • This field is for validation purposes and should be left unchanged.